fonato
22.07.2022 02:50

Написать программу на языке паскаль
9. дан массив натуральных чисел а(n), значения элементов которого лежат в диапазоне [200,1000]. найти:
а) сумму элементов массива, цифровая записи которых начинается с цифры 4
б) максимальный элемент среди тех, которые не являются простыми.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sokolovvw1
21.04.2020 15:40

1. множество символов для записи текста называют алфавитом

2 полное количество символов в алфавите называют мощностью

3 за единицу информации при алфавитном подходе принято считать вес 1 символа алфавита

4 2

5 это вес 1 символа в двухбитном алфавите

6 информационный объем определяется по формуле I=K*i, где к-количество символов в тексте, а i - вес одного символа

7 8 бит

8 256 символов

9 потому, что он строится только на мощности алфавита

10 N- мощность алфавита, i -вес одного символа

11 алфавитный подход к измерению информации позволяет определить количество информации, заключенной в тексте

12 N=2^i

13 I=K*i, где К -количество символов в тексте, а i - вес одного символа

14 при алфавитном подходе смысл сообщения не учитывается, важно только какой алфавит использовался

15 количество информации, заключенное в сообщении, определяется объемом знаний, который несет это сообщение получающему его человеку. Сообщение содержит информацию для человека, если заключенные в нем сведения являются для этого человека новыми и понятными и, следовательно пополняют его знания.

16 сообщение, уменьшающее неопределенность знаний в два раза, несет для него 1 бит информации.

17

0,0(0 оценок)
Ответ:
mstella2003
17.09.2020 10:57
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота