tans83lsk
10.07.2020 20:23

Надо
пара элементов в массиве называется симметричной , если эти элементы находятся на одинаковом расстоянии от концов массива. так в массиве размером n симметричными будут пары элементов с порядковыми номерами 1 и n , 2 и n - 1 и т.д. (при нумерации с единицы). напишите программу, которая заполняет массив из n элементов случайными целыми числами в диапазоне [ a , b ] и определяет номера двух симметричных элементов этого массива, сумма которых чётная и максимальная среди всех пар симметричных элементов. если ни одной такой пары нет, нужно вывести два нуля. если есть несколько таких пар, нужно вывести номера элементов, составляющих пару, ближайшую к центру массива.

входные данные

входная строка содержит три числа: границы диапазона случайных чисел a и b , а также размер массива n . все числа разделены пробелами. гарантируется, что 0 < n ≤ 1 .

выходные данные

в первой строке программа должна вывести n элементов построенного массива, разделив их пробелами, а во второй строке – номера двух симметричных элементов массива, имеющих максимальную чётную сумму. если ни одной такой пары нет, нужно вывести два нуля.

примеры
входные данные
10 20 10
выходные данные
10 10 19 12 13 17 13 11 14 14
5 6
п.с. питон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ejdncenejfjdj
12.01.2022 01:02

А)

program c1;

var

 a, b: integer;

 c: real;

begin

 a := 2;

 b := 3;

 c := a + 1 / 3;

 write(c);

end.

Б)

program c2;

var

 a, b: integer;

 c: real;

begin

 a := 2;

 b := 3;

 c := a + 4 / 2 * 3 + 6;

 write(c);

end.

В)

program c3;

var

 a, b: integer;

 c: real;

begin

 a := 2;

 b := 3;

 c := a + 4 / 2 * 3;

 write(c);

end.

Объяснение:

А)

program c1;  // Название программы

var  // Раздел для описания переменных

 a, b: integer;  // Объявление целочисленных переменных

 c: real;  // Объявление вещественной переменной

begin  // Начало программы

 a := 2;  // a = 2

 b := 3;  // b = 3

 c := a + 1 / 3;  // c = a + 1 ÷ 3

 write(c);  // Выводим ответ

end. // Конец программы

Б)

program c2;  // Название программы

var  // Раздел для описания переменных

 a, b: integer;  // Объявление целочисленных переменных

 c: real;  // Объявление вещественной переменной

begin  // Начало программы

 a := 2;  // a = 2

 b := 3;  // b = 3

 c := a + 4 / 2 * 3 + 6; // c = a + 4 ÷ 2 × 3 + 6

 write(c);  // Выводим ответ

end. // Конец программы

В)

program c3;  // Название программы

var  // Раздел для описания переменных

 a, b: integer;  // Объявление целочисленных переменных

 c: real;  // Объявление вещественной переменной

begin  // Начало программы

 a := 2;  // a = 2

 b := 3;  // b = 3

 c := a + 4 / 2 * 3; // c = a + 4 ÷ 2 × 3

 write(c);  // Выводим ответ

end. // Конец программы

0,0(0 оценок)
Ответ:
ykim1337
07.12.2020 12:05

abs(−16) = 16

sqr(b) = 256

sqr(b + b) = 1024

Объяснение:

program x1;  // Название программы

var  // Раздел для описания переменных

 a, b, c: integer; // Объявление целочисленных переменных:

a - хранение первого введенного с клавиатуры числа;

b - хранение второго введенного с клавиатуры числа;

с - хранение максимального из них.

begin  // Начало программы

 a := -16;  // Присваиваем значение "-16" в переменную а

 b := abs(a);  // Присваиваем модуль числа а в переменную b

 writeln('abs(−16)=', b);  // Выводим в консоль

 c := sqr(b);   // Присваиваем квадрат числа b в переменную c

 writeln('sqr(b)=', c);  // Выводим в консоль

 c := sqr(b + b);  // Присваиваем квадрат числа b + b в переменную c

 writeln('sqr(b+b)=', c);  // Выводим в консоль

end. // Конец программы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота