Ilya2569
20.09.2020 23:23

Написать программу на c++ которая выводит пирамиду из чисел. с клавиатуры водится число и до этого числа строится пирамида. вот как должно выглядеть(пример)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Арусяк122
11.09.2020 11:24

#include <iostream>

using namespace std;

int main()

{

 int n, i, j;

 string s, c;

 cout << "N = ";

 cin >> n;

 s = string(n, ' ');

 for (i = 1; i <= n; i++) {

   cout << "\n" << s;

   s.erase(s.size() - 1);

   for (j = 1; j <= i; j++) {

     if (n <= 9)

       c = " ";

     else

       c = i <= 9 ? "  " : " ";

     cout << c << i;

   }

 }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота