прждлшеджж
30.12.2021 21:37

Напишите программу на любом языке, главное уточните какой

ограничение времени 1 секунда

ограничение памяти 32mb

ввод matrix.in

вывод matrix.out

фирма по производству новых многоэлементных электронных матриц запускает новую линию, комплектуя ее узлом проверки готовой матрицы. узел засвечивает матрицу, подает напряжение на ее ячейки и считывает показания коэффициентов преломления каждой ячейки в виде цифр от 0 до 9. из этих показаний формируется таблица и записывается в файл. для оценки качества матрицы используется суммы коэффициентов преломления по каждой строке матрицы, а также количество сумм с максимальным значением из всех сумм коэффициентов по данной матрице. напишите программу, определяющую требуемые характеристики матрицы по имеющейся таблице коэффициентов преломления.

формат ввода

в первой строке входного файла matrix.in записано два натуральных числа, не превышающих 1024 - количество строк прямоугольной матрицы и количество ячеек в каждой строке. в последующих строках записаны без пробелов коэффициенты преломления.

формат вывода

в файл matrix.out следует вывести суммы коэффициентов преломления по одному в строке. последней строкой файла следует вывести количество сумм с максимальным значением из всех сумм коэффициентов по данной матрице. таким образом, в файле должно быть записано столько чисел, из скольких строк состоит электронная матрица, плюс одно число.

пример

ввод вывод

5 5 14

73022 25

95308 26

59282 18

55332 26

21797 2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Daniilyushka
15.12.2021 15:42
Const
  n=7;
type
  V=array[1..n] of real;
procedure mReplace(t:real;var a:V;var k:integer);
var
  i:integer;
begin
  k:=0;
  for i:=1 to n do
    if a[i]<t then begin a[i]:=t; Inc(k) end
end;

var
  T:real;
  i,k1,k2:integer;
  P,C:V;
begin
  Write('Введите значение T: '); Read(T);
  Writeln('Введите элементы массива P');
  for i:=1 to n do Read(P[i]);
  Writeln('Введите элементы массива C');
  for i:=1 to n do Read(C[i]);
  mReplace(T,P,k1); mReplace(T,C,k2);
  if k1>k2 then
  begin
    Writeln('Измененнный массив Р'); for i:=1 to n do Write(P[i],' ')
  end
  else
    if k2>k1 then
  begin
    Writeln('Измененнный массив C'); for i:=1 to n do Write(C[i],' ')
  end
  else Writeln('Число замен в массивах равно ',k1)
end.

Тестовое решение:
Введите значение T: 0.005
Введите элементы массива P
0.001 1.54 -2.75 0.002 -0.1 1.2 -0.47
Введите элементы массива C
-5.74 0.0001 4.1 7.24 -1.5 2.9 0.004
Измененнный массив Р
0.005 1.54 0.005 0.005 0.005 1.2 0.005
0,0(0 оценок)
Ответ:
Aina64
15.12.2021 15:42
#include "iostream"
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
#include <cstdio>
using namespace std;
void main()
{
setlocale(LC_ALL, "Russian");
 int i;
 double s = 0, k, size;
 double mas[200];
 cout << "Введите размерность массива:";
 cin >> size;
 srand(time(NULL));
 for (i = 0; i < size; i++)
{
 mas[i] = 0 + rand() % 100; cout << mas[i] << " ";
 }
cout << endl;
 for (i = 0; i < size; i++)
{
 s = s + mas[i];
 }
k = s / size;
 cout << "Среднее арифметическое:" << k <<endl;
 system("pause");
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота