Soniadesor
01.03.2022 23:11

Написать программу решения примера на паскале(15 вариант)
45 )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Den12364665
17.03.2023 07:05

program HelloWorld;

var a: array of integer;

var N, min, max, i, variable:integer;

begin

   min := 32767;

   max := 0;

   readln(N);

   for i := 0 to N do begin  

       readln(variable);

       if (variable > 0) and (variable mod 2 = 0) and (variable > max) then

           max := variable;

       if (variable > 0) and (variable mod 2 = 0) and (variable < min) then

           min := variable;

   end;

   if (max <> 0) and (min <> 32767) then

       writeln(min, ' ', max)

   else  

       writeln(-1);

end.

0,0(0 оценок)
Ответ:
arystan307
17.03.2023 07:05

program HelloWorld;

var a: array of integer;

var N, min, max, i, variable:integer;

begin

   min := 32767;

   max := 0;

   readln(N);

   for i := 0 to N do begin  

       readln(variable);

       if (variable > 0) and (variable mod 2 = 0) and (variable > max) then

           max := variable;

       if (variable > 0) and (variable mod 2 = 0) and (variable < min) then

           min := variable;

   end;

   if (max <> 0) and (min <> 32767) then

       writeln(min, ' ', max)

   else  

       writeln(-1);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота