sasha2005k1
01.10.2021 08:30

Составить программу обработки динамической структуры данных : по стеку l построить два стека: l1 – из элементов, имеющих четное значение веса, и l2 – из элементов, имеющих нечетное значение веса. язык с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
QbQbQb
22.12.2022 11:11
               цена     незн.   цветик     тороп.    док.
пароход   2         50км      100км      -          60км
поезд       1         40км       20км    10км      30км
самолёт    4         100км      -         200км

50+40+100=190 км проехал незнайка
100+20=120км проех.цветик
10+200=210км проех тороп.            всего 190+120+210+90=610 км
60+30= 90км проех доктор

50х2+40+100х4=100+40+400=540 коп.=5руб 40 коп - нейзнайка
100х2+20=220 коп=2руб 20коп-  цветик
10+200х4 = 810 коп=8руб 10коп - торопыжка
  60х2+30=150коп=1руб 50коп - доктор
всего 540+220+810+150=1720 коп = 17руб 20коп
0,0(0 оценок)
Ответ:
aidanuraim
17.03.2022 23:40

import static java.lang.Math.*;

class MySolution {

   public static void main(String[] args) {

       double min = sin(pow(0, 2) + 5 * 0) * cos(3 * pow(0, 2) - 0), minArg = 0;

       for (double x = 0.4; x < 8; x += 0.4) {

           double y = sin(pow(x, 2) + 5 * x) * cos(3*pow(x, 2) - x);

           if (y < min) {

               min = y;

               minArg = x;

           }

       }

       double[] A = new double[1];

       A[0] = min;

       System.out.printf("Наименьшее значение функции: " + A[0] + "\nПри значении аргумента x: " + "%.1f", minArg);

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота