bagdasaryaneedik6390
08.03.2023 05:55

Написать программу на с++ переставить первую и последнюю цифру в записи натурального числа n.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pomorcevakata98
09.10.2020 10:47

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   int number, coun = 0, d, first, last;

   double pwr;

   setlocale(LC_ALL, "Russian");

   cout << "Поменять первую и последнюю цифры числа>" << endl;

   cout << "Введите число: ";

   cin >> number;

   d = number;

   while (d > 0)

   {

       d /= 10;

       coun++;

       cout << "count = " << coun << endl;

   }

   pwr = pow(10, coun-1);

   //к примеру число равно 321

   //first = 3

   //last = 1

   //number = 32

   //number = 323

   //number = 23

   //number = 123

   first = number / (int)pwr;

   last = number % 10;

   number /= 10;

   number = number * 10 + first;

   number %= int(pwr);

   number += last * int(pwr);

   cout << "Result: " << number << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
айлан8
09.10.2020 10:47

Вопрос является альтернативой к вопросу:

С тем лишь отличием, что решение тут через математические функции.

Хоть алгоритм по времени и не оптимизируется, но является более быстрым решением алгоритма из вопроса указанного выше.

Скорость работы кода в среднем до 40% выше чем в предыдущем.

По дополнительным вопросам в комменты.


за отметку "лучшее" решение и нажатую кнопочку " " тут и в моем аккаунте.


Написать программу на с++ переставить первую и последнюю цифру в записи натурального числа n.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота