Войти
Регистрация
Спроси ai-bota
totty1
26.04.2020 01:53
Дан массив b(m), m≤15 . все элементы с четными номерами удвоить, а с нечетными - заменить нулями. вывести на печать исходный и переформированный массив. на языке с++
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
sodzirovna
09.02.2022 19:26
Нужно написать программу на питоне, я попытался и у меня не вышло. Создать функцию-генератор, которая генерирует вводимое с клавиатуры число целых чисел из диапазона...
cadova
01.02.2022 04:34
Определи правельный порядок действий алгоритма создания фильтра. ...
firsovata2017tatyana
06.04.2021 07:01
Вкаком порядке и какие числа нужно вывести, чтобы после выполнения следующих операторов было выведено 123?...
Vova89898
14.07.2022 13:07
:решите с языка программирования pascal. уличный продавец газет получает а рублей с продажи каждой газеты. всего он продал 70 газет. составьте программу, которая...
AlicaMinenkova
26.11.2021 16:42
По заданным в варианте IP-адресу узла сети и маске определите адрес сети. IP-адрес: 12.16.196.10 Маска: 255.255.224.0...
nurkenalmazbek
17.01.2020 20:47
В одном множестве 40 элементов, в другом – 30. Какое максимальное количество элементов может быть в их объединении? 10304070-101200...
varkraft
23.03.2021 21:49
Информатика 4кл онлайн мектеп...
Manber
30.11.2022 16:30
Всемирной свободной интернет-энциклопедии подготовьте небольшой рассказ по одной из следующих тем: 1. Роботы и древнегреческие мифы.2. Первые механические прототипы...
AngelRush0
29.05.2022 20:31
Этап подготоаки документа на компьютере, при которых вы просмаириваете его, исправляете обнаруженные ошибки и вносите необходимые изменения. 14 букв...
VikaSh86
29.05.2022 20:31
Решите в программе паскаль: даны числа a,b,если остаток при целочисленном деление равен 0. число а присвоить частное от деление, а иначе число а присвоить произведение...
Ответ:
niga24
08.10.2020 12:02
#include <iostream>
using namespace std;
int main() {
int m;
cout << "m = ", cin >> m, cout << "\n";
int b[m];
srand(time(NULL));
cout<<"array:\n";
for (int i=0; i<m; i++)
{
b[i]=rand() % 50;
cout<<b[i]<<" ";
}
cout << "\n";
for (int i=0; i<m; i++)
if ((i+1)%2==0) b[i] *= 2;
else b[i]=0;
for (int i=0; i<m; i++) cout << b[i] << " ";
cout << "\n";
return 0;
}
Пример:
m = 10
array:
47 3 29 46 36 31 2 2 20 20
0 6 0 92 0 62 0 4 0 40
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота