Войти
Регистрация
Спроси ai-bota
Danil244564
11.10.2022 02:13
Водномерном массиве, заданным рандомными числами и состоящем из 10 вещественных элементов, вычислить: сумму элементов массива, расположенных между первым и последним положительными элементами. с++
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
здрасти2003
01.02.2020 15:19
Иначе двойку поставят(( 55 1.чему будет равно а в конце выполнения каждого алгоритма: а) а: =2 в: =5 а: =(в+3)/2 в: =2*в+а а: =в/2 а-? б) а: =2 в: =5 а: =(а+в)*2 а: =а-в...
Katellil3
01.02.2020 15:19
Что такое архивация файлов? когда её применяют?...
pudgenamide
22.07.2021 14:33
Учитель работал в каталоге d: \материалы к урокам\10 класс\практические работы затем перешел в дереве каталогов на уровень выше, спустился в подкаталог лекции и удалил из...
YYanamaiY
22.07.2021 14:33
Pascal цикл while последовательно вводятся числа, найти их сумму. ввод остановить после ввода второго нуля....
WaterdropE
03.05.2022 12:54
Как называется инструментальная программа, осуществляющая трансляцию всей исходной программы в машинные коды?...
megais
12.02.2023 08:14
Дима забыл пин-код денежной карточки.но он точно знает что это четырехзначное целое число, причем оно делится как на 2, так и на 11, и начинается и заканчивается на одну...
Кекушка36
19.12.2020 19:07
Для кодирования букв и, д, т, о, x решили использовать двоичное представление чисел 0, 1, 2, 3 и 4 соответственно (с сохранением одного незначащего нуля в случае одноразрядного...
Группа134ПО
20.04.2023 18:36
Составить блок схему для решения квадратного уравнения : ах^2+вх+с=0, а неравно 0...
Litel1
24.07.2021 19:09
Переложить 4 детали для починки пола в замке....
Kaldomova2014
29.04.2022 04:18
Что будет в результате работы программы: a=input(); b=input(); c=a+b; print (c). Входные данные a=21 b=33...
Ответ:
Dragolord
07.10.2020 16:07
#include <stdlib.h>
#include <iostream>
#include <iomanip>
using namespace std;
int main() {
const int n = 10;
double a[n];
double s=0;
int i1=0, i2=n-1;
srand(time(0));
for (int i = 0; i < n; i++){
a[i]=-50 + (101.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << setprecision (2) << a[i];
}
cout <<endl;
while (a[i1]<=0) i1++;
while (a[i2]<=0) i2--;
for (int i = i1+1; i < i2; i++) s += a[i];
cout << "s = " << s << endl;
}
Пример:
-27.52 34.26 -1.18 -8.80 35.24 6.73 18.42 -34.25 -30.21 44.03
s = -14.06
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота