demoplus1
13.03.2021 16:50

Склавиатуры вводят слова.составьте программу,которая выводит цифры этого числа .например: семь нуль три один шесть четыре ,должно вывести 7 0 3 1 6 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
маруська62
08.09.2020 13:53
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var w1:=Arr('ноль','один','два','три','четыре','пять','шесть',
    'семь','восемь','девять');
  var w2:=Arr('0','1','2','3','4','5','6','7','8','9');
  var a:=ReadlnString('->').ToWords;
  foreach var w in a do begin
    var i:=w1.FindIndex(p->p=w);
    if i>=0 then Write(w2[i],' ')
    end;
end.

Пример
-> семь ноль три один шесть четыре
7 0 3 1 6 4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота