akrikay13
05.11.2022 01:05

Pacal 1) требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. программист торопился и написал программу неправильно. вот она: var x,y: real; begin readln(x,y); if y > = -1 then if y < = sin(x) then if y > = x-1 then write('принадлежит') else write('не принадлежит') end. последовательно выполните следующее: 1) пример таких чисел x, y, при которых программа неверно решает поставленную . 2) укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (это можно сделать несколькими поэтому можно указать любой доработки исходной программы).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Xoroshiyi
26.07.2022 17:43
Производительность (быстродействие) ПК – возможность компьютера обрабатывать большие объёмы информации. Определяется быстродействием процессора, объёмом ОП и скоростью доступа к ней (например, Pentium III обрабатывает информацию со скоростью в сотни миллионов операций в секунду)Производительность (быстродействие) процессора – количество элементарных операций выполняемых за 1 секунду.
Тактовая частота процессора (частота синхронизации) - число тактов процессора в секунду, а такт – промежуток времени (микросекунды) за который выполняется элементарная операция (например сложение). Таким образом Тактовая частота - это число вырабатываемых за секунду импульсов, синхронизирующих работу узлов компьютера. Именно ТЧ определяет быстродействие компьютера
Задается ТЧ специальной микросхемой «генератор тактовой частота», который вырабатывает периодические импульсы. На выполнение процессором каждой операции отводится определенное количество тактов. Частота в 1Мгц = 1миллиону тактов в 1 секунду.  Превышение порога тактовой частоты приводит к возникновению ошибок процессора и др. устройств. Поэтому существуют фиксированные величины тактовых частот для каждого типа процессоров, например: 2,8 ;  3,0  Ггц  и тд
Разрядность процессора – max длина (кол-во разрядов) двоичного кода, который может обрабатываться и передаваться процессором целиком.
Разрядность связана с размером специальных ячеек памяти – регистрами. Регистр в 1байт (8бит) называют восьмиразрядным, в 2байта – 16-разрядным и тд.  Высокопроизводительные компьютеры имеют 8-байтовые регистры (64разряда)
Время доступа - Быстродействие модулей ОП, это период времени, необходимый для считывание min порции информации из ячеек памяти или записи в память. Современные модули обладают скоростью доступа свыше 10нс (1нс=10-9с)
Объем памяти (ёмкость) –  max объем информации, который может храниться в ней.
Плотность записи – объем информации, записанной на единице длины дорожки (бит/мм)
Скорость обмена информации – скорость записи/считывания на носитель, которая определяется скоростью вращения и перемещения этого носителя в устройстве
0,0(0 оценок)
Ответ:
Чебурашка1234567890
26.07.2022 17:43
Производительность (быстродействие) ПК – возможность компьютера обрабатывать большие объёмы информации. Определяется быстродействием процессора, объёмом ОП и скоростью доступа к ней (например, Pentium III обрабатывает информацию со скоростью в сотни миллионов операций в секунду)Производительность (быстродействие) процессора – количество элементарных операций выполняемых за 1 секунду.
Тактовая частота процессора (частота синхронизации) - число тактов процессора в секунду, а такт – промежуток времени (микросекунды) за который выполняется элементарная операция (например сложение). Таким образом Тактовая частота - это число вырабатываемых за секунду импульсов, синхронизирующих работу узлов компьютера. Именно ТЧ определяет быстродействие компьютера
Задается ТЧ специальной микросхемой «генератор тактовой частота», который вырабатывает периодические импульсы. На выполнение процессором каждой операции отводится определенное количество тактов. Частота в 1Мгц = 1миллиону тактов в 1 секунду.  Превышение порога тактовой частоты приводит к возникновению ошибок процессора и др. устройств. Поэтому существуют фиксированные величины тактовых частот для каждого типа процессоров, например: 2,8 ;  3,0  Ггц  и тд
Разрядность процессора – max длина (кол-во разрядов) двоичного кода, который может обрабатываться и передаваться процессором целиком.
Разрядность связана с размером специальных ячеек памяти – регистрами. Регистр в 1байт (8бит) называют восьмиразрядным, в 2байта – 16-разрядным и тд.  Высокопроизводительные компьютеры имеют 8-байтовые регистры (64разряда)
Время доступа - Быстродействие модулей ОП, это период времени, необходимый для считывание min порции информации из ячеек памяти или записи в память. Современные модули обладают скоростью доступа свыше 10нс (1нс=10-9с)
Объем памяти (ёмкость) –  max объем информации, который может храниться в ней.
Плотность записи – объем информации, записанной на единице длины дорожки (бит/мм)
Скорость обмена информации – скорость записи/считывания на носитель, которая определяется скоростью вращения и перемещения этого носителя в устройстве
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота