Tolganay11
30.11.2020 12:59

Написать программу в pascal используя циклы. а)s квадратов чисел от 1 до n+1. б)p кубов чисел от 1 до n-5. в)частное от деления s на p. записать это все в одну программу.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
den222276
03.10.2020 17:16
// var n,s,p,i:integer; - для значений n < 18
var n,s,i:integer; p:real;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n+1 do s:=s+i*i;
writeln('s = ',s);
p:=1;
for i:=1 to n-5 do p:=p*i*i*i;
writeln('p = ',p);
writeln('s/p = ',s,'/',p,' = ',s/p);
end.

Пример:
n = 10
s = 506
p = 1728000
s/p = 506/1728000 = 0.000292824074074074
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота