Отличница4561
23.05.2021 01:45

Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в диапазоне от 0 до 1000 после чего на экран выводится сам массив в одну строку следующей строке номер максимального элемента пробел максимальный элемент

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
natalikohan12p0domq
03.10.2020 08:49
Так уже решал такую задачу:
const n=20;
var
  a:array[1..n] of integer;
  i,max,nmax:integer;
begin
  max:=0;
  for i:=1 to n do begin
    a[i]:=random(1001);
    if a[i] >max then begin
      nmax:=i;
      max:=a[i];
    end;
    write(a[i]:5);
  end;
  writeln;
  writeln(nmax,' ',a[nmax]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота