aminapilipenko
17.05.2022 17:45

Тема: pascal. циклы 1)составить программу подсчета суммы нечетных делителей,кратных трем,натурального числа n 2) составить программу,вычисляющую x^n,где n-целое положительное число. 3) одноклеточная амеба каждые 3 часа делится на 2 клетки.определить,сколько амеб будет через 3,6,9, часа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yurasokolov232
06.07.2020 23:04
1
var n,s,i:integer;
begin
readln(n);
for i:=3 to n do
  if (n mod i=0) and (i mod 3=0) and (i mod 2>0) then
    s:=s+i;
writeln ('ответ: ',s);
end.

2
var
  n,i:integer;
  x,y:real;
begin
readln(x,n);
y:=1;
for i:=1 to n do y:=y*x;
writeln (x,'^',n,'=',y);
end.

3
var n,i:integer;
begin
n:=1;
writeln('Часы ',' Кол-во');
while i<25 do
  begin
  writeln(i:3,n:6);
  n:=n*2;
  i:=i+3;
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота