Efimenko34
20.07.2022 16:42

Напишите программу вычисления наибольшего общего делителя двух натуральных чисел. используйте оператор repeat,while.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Maxi4601
02.07.2020 12:56
Function NOD(a, b: integer): integer;
begin
  while a <> b do
    if a > b then a := a - b
    else b := b - a;
  NOD := a
end;

begin
  writeln('НОД(264;5436)=', NOD(264, 5436))
end.

Тестовое решение:
НОД(264;5436)=12
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота