tohaahuevshyu
05.06.2023 16:28

Создание программы расчета.. Шар радиусом R помещается в канавку в виде ромба со сторонами P и Q Можно ли пройти под углом? Напишите программу, которая его определяет.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Рита0Венес
17.12.2020 04:17
Var
    a, b, c, p: real;
    a1, b1, c1: real;
    a2, b2, c2: real;

function SideLength(a1, a2, b1, b2: real): real;
begin
    SideLength := sqrt(sqr(a1 - b1) + sqr(a2 - b2));
end;

begin
    writeln('1.Найти сумму трех чисел');
    readln(a, b, c);
    writeln(a + b + c);
    
    writeln('2.Катеты прямоугольного треугольника известны.Найти гипотенузу.');
    readln(a, b);
    writeln(sqrt(a * a + b * b));
    
    writeln('3.Найти среднеарифметическое двух чисел.');
    readln(a, b);
    writeln((a + b) / 2);
    
    writeln('4.Найти длину окружности,если известна площадь круга.');
    readln(a);
    writeln(sqrt(a / pi) * 2 * pi);
    
    writeln('5.Какой процент составляет число а от числа b.');
    readln(a, b);
    writeln(a / b * 100);
    
    writeln('6.Найдите площадь треугольника с формулы Герона.');
    readln(a, b, c);
    p := (a + b + c) / 2;
    writeln(sqrt((p - a) * (p - b) * (p - c) * p));
    
    writeln('7.Найдите площадь кольца,если его толщина I см,диаметр внутри круга d см.');
    readln(a, b);
    c := a + b;
    writeln(pi * (c * c - b * b));
    
    writeln('8.Вычислите площадь треугольника заданного координатами вершин.');
    readln(a1, a2, b1, b2, c1, c2);
    writeln(((a1 - c1) * (b2 - c2) - (a2 - c2) * (b1 - c1)) / 2);
    
    writeln('9.Вычислить длинны сторон треугольника по заданным координатам его вершин.');
    a := SideLength(a1, a2, b1, b2);
    b := SideLength(c1, c2, b1, b2);
    c := SideLength(a1, a2, c1, c2);
    writeln(a, ' ', b, ' ', c);
end.
0,0(0 оценок)
Ответ:
alese4kas94p0cen0
06.06.2020 01:29
Статические модели относятся к объектам, практически неизменяющимся во времени или рассматриваемым в отдельные временные сечения. Динамические модели воспроизводят изменения состояний («движение») объекта с учетом как внешних, так и внутренних факторов.

Для динамических моделей часто вводят понятия стационарность и нестационарность. Чаще всего стационарность выражается в неизменности во времени некоторых физических величин: стационарным является поток жидкости с постоянной скоростью, стационарна механическая система, в которой силы зависят только от координат и не зависят от времени.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота