Итоговая работа №1.9 класс Задание 1. Напишите программу, которая считывает с клавиатуры 3 целых числа (переменные x, y, z) и выводит на экран формулы с подставленными значениями из переменных и их решение: 1. x+y+z? 2. (x+2) - (3+у?) 3. x-3y+ 2*z– 15 Пример: Входные данные (ВВОДЯТСЯ ПРИ КЛАВИАТУРЫ): »x=5 »y=3 >>Z=-4 Выходные данные: >>50 >>29 >>7 Подсказка: Для ввода целого числа при клавиатуры используйте команду int(input(); Степень можно найти при символа (пример: 5**2 = 25). . .
Первый вариант программы: Const N = 5; Var A:array[1..N] of integer; i:integer; S:real; Begin Randomize; S:=0; Write('Исходный массив:'); For i:= 1 to N do Begin A[i]:=random(21)-10; Write(' ',A[i]); S:=S+A[i]; End; WriteLn; WriteLn('Сумма его элементов: ',S); End.
Второй вариант программы: Const N = 13; Var A:array[1..N] of integer; i,S,B:integer; Begin Randomize; S:=0; Write('Исходный массив:'); For i:= 1 to N do Begin A[i]:=random(21)-10; Write(' ',A[i]); End; WriteLn; Write('Введите номера пяти элементов: '); For i:= 1 to 5 do Begin Read(B); S:=S+A[B]; End; WriteLn('Их сумма равна: ',S); End.
Пример: Исходный массив: 0 -9 6 4 -7 -1 9 -7 -2 -4 -6 4 -1 Введите номера пяти элементов: 3 4 7 12 1 Их сумма равна: 23
Const N = 33; Var A:array[1..N] of integer; i:integer; Begin Randomize; Write('Исходный массив:'); For i:= 1 to N do Begin A[i]:=random(100000)-50000; Write(' ',A[i]); End; WriteLn; WriteLn; Write('Трёхзначные числа:'); For i:= 1 to N do if (99<Abs(A[i]))and(Abs(A[i])<1000) then Write(' ',A[i]); WriteLn; Write('Номера четырёхзначных чисел:'); For i:= 1 to N do if (999<Abs(A[i]))and(Abs(A[i])<10000) then Write(' ',i) End.