Znatokkekgg
13.02.2020 08:40

Написать программу, которая будет имитировать один раунд игры в кости между двумя игроками (Игрок 1, Игрок 2). Значения чисел после броска лежит в диапазоне (1, 6). Используйте стандартную конструкцию if-else, а так же инструкцию print() и символьную графику для красивого оформления результата игры. Так же используйте полученные на уроке знания. программа пайтон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dgostishev
25.05.2021 20:41
Var
  a,b,i,n,j,l,ier:integer;
  s:string;
  p:boolean;
begin
  Write('Введите границы интервала в виде пары натуральных чисел ');
  Read(a,b);
  n:=0;
  for i:=a to b do
  begin
    Str(i,s);
    l:=Length(s);
    if l=1 then Inc(n)
    else begin
      j:=1;
      repeat
        p:=(s[j]=s[l-j+1]);
        Inc(j)
      until (j>l) or (not p);
      if p then Inc(n)
    end
  end;
  Writeln('Количество палиндромов равно ',n)
end.

Тестовое решение:
Введите границы интервала в виде пары натуральных чисел 1550 2450
Количество палиндромов равно 10
0,0(0 оценок)
Ответ:
dianacm789
19.06.2020 09:43
Const
  n=20;
var
  a:array[1..n] of integer;
  b,c:array[1..n div 2] of integer;
  i:integer;
begin
  { инициализация }
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i]:=Random(99)+1; { Интервал [1..99] }
    Write(a[i],' ');
  end;
  Writeln;
  { Формирование массивов-результатов }
  for i:=1 to n div 2 do
  begin b[i]:=a[2*i-1]; c[i]:=a[2*i] end;
  { Вывод результатов }
  Writeln('Массив, сформированный из значений с нечетными номерами');
  for i:=1 to n div 2 do Write(b[i]:3); Writeln;
  Writeln('Массив, сформированный из значений с четными номерами');
  for i:=1 to n div 2 do Write(c[i]:3); Writeln
end.

Тестовое решение:
Элементы массива
20 99 21 39 51 96 76 1 64 32 41 80 19 30 37 55 40 24 60 50
Массив, сформированный из значений с нечетными номерами
 20 21 51 76 64 41 19 37 40 60
Массив, сформированный из значений с четными номерами
 99 39 96  1 32 80 30 55 24 50
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота