YeGoR17
20.09.2022 00:01

Напишите программу, которая вычисляет среднее арифметическое массива из 10 элементов. На паскале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
azarovanadejdaozzbir
24.03.2020 05:32

Объяснение:

В большинстве случаев, когда человек получает информацию, он также её обрабатывает и сохраняет

нюхая цветы получаю информацию в виде запаха, пробуя еду получаю информацию в виде вкуса, слушая лекцию получаю информацию, читая книгу получаю информацию, на мастер классах учусь новому

читаю книгу я также обрабатываю полученную информацию; слушаю лекцию я также обрабатываю полученную информацию; решая кроссворд я обрабатываю информацию, что бы решить вопрос; решая домашнее задание я обрабатываю задания; играя в игру я обрабатываю информацию, что бы делать какие-то действия.

Читая книгу я также и запоминаю прочитанное; слушаю лекцию я также запоминаю услышанное; нюхая цветы я запоминаю их запах; кушая еду я запоминаю её вкус; когда я учу стих, я запоминаю информацию

Рассказывая стих я передаю слушателям информацию; объясняя задачу я передаю информацию слушателям; общаясь с кем то я передаю информацию; уча брата говорить я передаю ему информацию; участвуя в опросе я передаю информацию

0,0(0 оценок)
Ответ:
murad2097
15.03.2020 02:57

//PascalABC.Net 3.1 сборка 1200

//написано в стиле обычного паскаля, должно работать

var

   number: integer;

   sum, sum_all, k: integer;

begin

   repeat

       write('Элемент последовательности => ');

       readln(number);

       

       if (number mod 10 = 2 ) and (number mod 4 = 0) then sum := sum + number;

       if (number <= 100) then k := k + 1;

       sum_all := sum_all + number;

   until number = 0;

   

   writeln('Сумма всех чисел, которые кратны 4 и заканчиваются на цифру 2 = ', sum);

   writeln('Сумма всех = ', sum_all);

   writeln('Кол-во чисел, которые не больше 100 = ', k);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота