Ozerck2002
28.02.2020 06:48

Нарисовать блок-схему и написать программу для следующей задачи: Посчитать сумму чисел, кратных 5. Программа получает на вход числа, условием окончания ввода чисел, является число 0. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 5.
Входные данные: 5, 12,30,0
выходные данные: сумма = 35

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Xonus
12.12.2021 06:06

Программа:

Pascal:

program cd6059e5;

var a, b, c, d, x, xx, f: real;

begin

 write('а = '); read(a);

 write('b = '); read(b);

 write('c = '); read(c);

 d := b*b - 4*a*c;

 f := sqrt(d);

 writeln('D = ', d);

 

 if d > 0 then begin

   writeln('√D = ', f);

   x := (-b-f)/(2*a);

   xx := (-b+f)/(2*a);

   writeln('x1 = ', x);

   writeln('x2 = ', xx);

 end;

 if d = 0 then x := -b/(2*a);

 if d < 0 then writeln('Корней нет.');

end.

Исправил вашу программу. Корни неверно вычислялись, пару других моментов поправил.

0,0(0 оценок)
Ответ:
мальчуган2
17.02.2022 22:29

#arr = [*map(int, input().split(' 0')[0].split())]  если числа вводятся в строчку , то раскомментируйте и используйте эту строку, а инициализацию массива arr и цикл while закомментируйте

arr = []

while 1:

   tmp = int(input())

   if tmp != 0:  # Читаем сколько угодно чисел пока не будет ноль

       arr.append(tmp)

   else:

       break

s = 0  # сумма двузначных чисел

k = 0  # количество двузначных чисел

for i in arr:

   if 10 <= i <= 99:  # итерируемся по циклу и если число двузначное

       s += i  # то прибавляем его к сумме

       k += 1  # счетчик двузначный чисел увеличиваем на один

print(s/k) if k > 0 else print('NO') #если количество двузначных > 0 то выводим среднее арифметическое s/k, если нет то выводим NO

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота