Ru5829
12.11.2021 01:54

Написать программу на c#, которая определяет попадает ли точка с заданными координатами в область, закрашенную на рисунке черным цветом. Результат работы программы вывести в текстовое сообщение. https://i.imgur.com/Q4SFNhA.png


Написать программу на c#, которая определяет попадает ли точка с заданными координатами в область, з

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kskskdksks
16.09.2021 01:30

Объяснение:

using System;

namespace ConsoleApp2

{

   class Program

   {

       static void Main(string[] args)

       {

           bool InArea = false;

           Console.Write("R=");

           double R = double.Parse(Console.ReadLine());

           Console.Write("x=");

           double x = double.Parse(Console.ReadLine());

           Console.Write("y=");

           double y = double.Parse(Console.ReadLine());

           // Проверяем попадает ли в полукруг

           if (x <= 0 && y >= 0 && x * x + y * y <= R * R) InArea = true;

           // Проверяем попадает ли в первую половинку треугольника

           // Уравнение прямой будет y=-2x  

           if (x > 0 && x <= R/2.0 && y >= -2*x && y<=0) InArea = true;

           // Проверяем попадает ли во вторую половинку треугольника

           // Уравнение прямой будет y=2x-2R  

           if (x > 0 && x <= R / 2.0 && y >= 2 * x - 2 * R && y <= 0) InArea = true;

           if(InArea) Console.WriteLine("Точка принадлежит области");

           else Console.WriteLine("Точка не принадлежит области");

           Console.ReadLine();

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота