NEW4IK
12.06.2020 04:50

Паскаль. Напишите программу, которая отделяет положительные элементы массива от отрицательных: переставляет все положительные (в том же порядке) в начало массива, а все отрицательные (в том же порядке) – в конец массива, все нулевые элементы должны оказаться в середине массива. входные данные:
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
выходные данные:
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yanachor25
11.04.2022 06:56
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
0,0(0 оценок)
Ответ:
дариана2006
28.08.2020 09:26

ответ:

объяснение: чтобы стать студентом по обмену, необходимо для начала поступить в вуз на родине, в котором есть отдел международного образования. этот отдел отвечает за сотрудничество с иностранными университетами, в том числе и в вопросе обмена.

главным условием для перевода является владение языком той страны, в которой собирается обучаться студент. для этого потребуется пройти соответствующий тест. срок обучение может занять от полугода до нескольких лет, вплоть до получения дипломы иностранного вуза. все зависит от того, по какой программе удастся достигнуть договоренности.

преимущество учебы по обмену — это возможность остаться после успешного завершения университета в другой стране, устроится на работу и получить гражданство.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота