Дора18119
15.09.2020 05:57

Какой оператор можно использовать для возврата результата в питон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
famapsix2015
30.07.2021 03:40
ответ:

30

Объяснение:

Присваиваем переменной x значение 7:

x:=7;

Присваиваем переменной s значение 0:

s:=0;

Объявляем цикл от 1 до 3, который будет каждый раз выполнять команды введённые между begin и end:

for i:=1 to 3 do begin

Присваиваем переменной s значение текущей s + x, то есть просто прибавляем x:

   s:=s+x;

Присваиваем переменной x значение текущей x + 3, то есть просто прибавляем 3:

   x:=x+3;end;

Итак, x изначально равен 7, а s - 0. Потом идёт цикл, в котором к s прибавляется x, после чего к s прибавляется 3. Цикл небольшой, можно и пройтись для наглядности:

i = 1        s := 0 + 7 = 7              x := 7 + 3 = 10i = 2       s := 7 + 10 = 17           x := 10 + 3 = 13i = 3       s := 17 + 13 = 30         x := 13 + 3 = 16

Как мы видим, конечное значение s равно 30.

0,0(0 оценок)
Ответ:
Илья164Умникум
30.04.2020 21:46

Какой оператор цикла желательно использовать, если известно число повторений тела цикла?

repeat <оператор1, …>until <условие>

while <условие>do <оператор>

for <параметр>:= <начальное значение>to<конечное значение> do<оператор>

2. Используется оператор for i:= -10 to 10 do…

После завершения выполнения тела цикла i = 10

3. Цикл в фрагменте программы

p:=1;

repeat

p:=p*0.1

until p>0.1;

будет исполнен:

1 раз

2 раза

бесконечное число раз

0 раз

3 раза

4. Цикл в фрагменте программы

a:=1;

b:=1;

while a+b<8 do

begin

a:=a+1; b:=b+2

end;

выполнится:

0 раз

3 раза

2 раза

1 раз

бесконечное число раз

5. Какой оператор цикла желательно использовать для записи алгоритмической конструкции, изображённой на схеме?

НЕТ СХЕМЫ. ОТВЕТИТЬ НА ВОПРОС НЕВОЗМОЖНО.

while <условие> do <оператор>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

repeat <оператор1, …> until <условие>

6. Какой оператор цикла желательно использовать, если известно условие выхода из цикла?

repeat <оператор1, …> until <условие>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

while <условие> do <оператор>

7. Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:

a:=1; b:=1;

while a<=32 do a:=a*2; b:=b*a;  //Обратите внимание! Нет begin end.

write (b)

32

256

64

128

8. Используется оператор for i:= -5 to 9 do…

При первом выполнении тела цикла i = -5

9. Чему равно значение переменной s после выполнения следующего фрагмента программы

Фрагмента программы нет! Задание решить нельзя!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота