VaLerusyaK
18.10.2022 01:27

решить через Python. 1. Сложные условия AND, OR, NOT
Введите три числа. Найдите их произведение.
Если их произведение меньше 20 или больше 30, то выведите сообщение «ДА», иначе выведите сообщение «НЕТ».
2. решить задачу на Python.
1. Найти сумму числового ряда s=1+1/2+1/3+1/4++1/n
Решаем задачу через цикл.
2. Даны 2 числа, они не равны. Найти минимальное. Заменить минимальное половиной суммы этих двух чисел, а большее число удвоенным произведением этих двух чисел.
3. решение задач.
1. найти сумму четных чисел из диапазона от 5 до 20.
2. найти произведение чисел кратных 7 из диапазона от 7 до 49.
3. найти произведение не четных чисел из диапазона от 3 до 10.
4. Нарисуйте на экране «прямоугольник» из двух видов символов.
5. составить программу на Python.
1. напечатать числа кратные 7 из диапазона от 50 до 90.
2. найти произведение чисел не кратных 8 из диапазона от 60 до 90.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ksenichka777
10.07.2020 19:07
1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write('Введите натуральное число любой длины :'); Readln(s);
  Write('Введите цифру, которую надо удалить: '); Readln(a);
  s1:='';
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString('Введите натуральное число любой длины :');
  var a:=ReadChar('Введите цифру, которую надо удалить: ');
  Write('Результат: ',s.Replace(a,''));
end.
0,0(0 оценок)
Ответ:
enevismane
21.08.2020 14:59
Проще всего складывать в столбик как обычные десятичные числа, но если в сумме число получится больше 8 (система восмиричная), то мы отнимаем 8, смотрим: меньше ли получившийся остаток 8, если нет, то снова отнимаем восемь и тогда записываем остаток, а в "ум" запишем число отнятых восьмерок

574+467=1263 (все числа в восьмиричной системе счисления)

так, складывая 4 и 7, получаем 11, что больше 8, поэтому отняв 8, получим цифру 3, которую и записываем как последнюю цифру числа (3 пишем, 1 в уме), далее складываем 6 и 7 и не забываем про 1, потому что в раз мы отняли всего одну восьмерку, получаем 14, но записываем только 6, а 1 в уме, затем 5, 4 и 1 - 2 пишем, 1  в уме, далее просто приписываем единицу, получаем 1263

P.S. несмотря на то, что кажется сложно, это немногим отличается от десятичной системы сложения в столбик
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота