strimersakarinа
15.05.2020 13:03

Напишите программу вычислення значения выражения y = x=int(in input("Введите число х')) # ввод данных y=x**2/2+2*x+x/5 print (результат=', y) ## формула # вывод ответа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anonimnostya
25.07.2022 12:36

1) a = int(input('Введите градусную меру угла:'))

2) if a < 90 and a > 0:

3)     print('Вы ввели градусную меру острого угла.')

4) if a == 90:

5)     print('Вы ввели градусную меру прямого угла.')

6) if a > 90 and a != 180 and a <= 360:

7)     print('Вы ввели градусную меру тупого угла.')

8) if a == 180:

9)     print('Вы ввели градусную меру тупого угла.')

10) if a > 360:

11)     print('Вы ввели слишком большую цифру, повторите попытку.')

12) if a <= 0:

13)     print('Вы ввели слишком маленькую цифру, повторите попытку.')

Объяснение:

1) Задаём переменную "a", которая принимает введенное человеком число.

2) Если "а" меньше 90 и больше 0, то:

3) Выводится в командной строке 'Вы ввели градусную меру острого угла.'

4) Если "a" равно 90, то:

5) Выводится в командной строке 'Вы ввели градусную меру прямого угла.' P.S.: мы ставим 2 знака "=", так как мы не задаем переменную, а ставим условие.

6) Всё тоже самое, но тут мы пишем, что "a" не будет считаться тупым при 180, используя "!=".

7, 8 и 9) Всё тоже самое.

10 - 13) Предсказываем возможные ошибки. Всё тоже самое.

0,0(0 оценок)
Ответ:
Ада20000
22.09.2022 06:48
var
  a, b, c, d, i, n, p: integer;
  x, y: real;

begin
  writeln('Задача 1, введите n =');
  read(n);
  for i := 1 to n do
    if i mod 2 = 0 then
      x := x + 1 / (2 * i + 1)
    else x := x - 1 / (2 * i + 1);
  writeln('Sum = ', x);
 
  writeln('Задача 2, введите a, b, c, d =');
  read(a, b, c, d);
  for i := a to b do
    if i mod c = d then writeln(i);
 
  writeln('Задача 3, введите n и n чисел =');
  read(n);
  a := 0; b := 0; c := 0;
  for i := 1 to n do
  begin
    read(p);
    if p = 0 then a := a + 1
    else if p < 0 then b := b + 1
    else if p > 0 then c := c + 1;
  end;
  writeln(a, ' ', b, ' ', c);
 
  writeln('Задача 5, введите x, p ,y =');
  read(x, p, y);
  n := 0;
  repeat
    x := round(x * (100 + p)) / 100;
    n := n + 1;
  until x >= y;
  writeln(n, ' лет');
 
  writeln('Задача 6, введите A, B =');
  read(a, b);
  repeat
    if (a mod 2 = 0) and (a div 2 >= b) then begin
      writeln(a, ' : 2 = ', a div 2);
      a := a div 2
    end
    else begin
      writeln(a, ' - 1 = ', a - 1);
      a := a - 1;
    end;
  until a <= b;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота