balatzkymaxp0a4t7
20.06.2021 18:14

ЗАДАНИЕ на вход программы подаются два различных целых числа а и b. Необходимо вывести эти
числа в порядке убывания.
Напиши программу на школьном алгоритмическом языке и нарисуй блок-схему полученного
алгоритма,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Катя870273
08.10.2021 08:56

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

 int a[5][5] =

 {

   {4,-5,8,-3,1},

   {-3,8,-1,1,-8},

   {9,6,6,-3,-7},

   {-7,-3,3,6,-7},

   {7,-3,-6,5,0},

 };

 int b[5][5];

 int i, j, cp, cm, sp, sm;

 setlocale(LC_ALL, "Russian");

 cout << "Массив A";

 for (i = 0; i < 5; i++) {

   cout << endl;

   for (j = 0; j < 5; j++) {

     cout << setw (4) << a[i][j];

   }

 }

 cp = cm = sp = sm = 0;

 for (i = 0; i < 5; i++) {

   for (j = 0; j < 5; j++) {

     if (a[i][j] >= -5)

       b[i][j] = a[i][j];

     else

       b[i][j] = - a[i][j];

     if (a[i][j] > 0) {

       cp++;

       sp += a[i][j];

     }

     if (a[i][j] < 0) {

       cm++;

       sm += a[i][j];

     }

   }

 }

 cout << endl << endl;

 cout << "Среднее значение положительных элементов = " << (float) sp / cp << endl;

 cout << "Среднее значение отрицательных элементов = " << (float) sm / cm << endl << endl;

 cout << "Массив B";

 for (i = 0; i < 5; i++) {

   cout << endl;

   for (j = 0; j < 5; j++) {

     cout << setw(4) << b[i][j];

   }

 }

 return 0;

}

0,0(0 оценок)
Ответ:
NastyaVait3
01.08.2022 12:32

Что это такое – египетская система счисления? Чтобы написать какое-либо число, использовали иероглифы, обозначавшие определенные числа, сумма которых равнялась нужному значению. Специальные обозначения имелись для чисел 1, 10, 100, 1000, 10000, 100000, 1000000. При написании нужного числа каждое обозначение использовалось до 9 раз. Запись в египетской системе счисления шла по возрастанию: вначале единицы, потом десятки, сотни и так далее. Причем писали, как правило, справа налево, но можно было и слева направо, сумма от этого не менялась. Использовалось и вертикальное написание, но тогда отсчет шел сверху вниз.

Объяснение:Использовалось два написания: Иероглифический, в котором употреблялись принятые иероглифы. Иератический, который являлся более схематичным и удобным на практике

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота