kostinak37
10.03.2020 09:26

Здравствуйте! Не могли вы написать программу, которая посчитает количество трехзначных чисел кратных четырём. Чисел изначально n. (через for)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
viktoriavasili
26.02.2021 09:13

var

 n, count, i: integer;

begin

 count := 0;

 write('Введите трехзначное число n: ');

 readln(n);

 if ((n < 100) or (n > 999)) then

   writeln(' Число не трехзначное!')

 else

 begin

   begin

     for i := 100 to n do

       if i mod 4 = 0 then count := count + 1;

   end;

   writeln(' Количество трехзначных чисел кратных четырем = ', count);

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота