bryadovasg
26.08.2020 08:51

НА ЯЗЫКЕ ПРГОРАМИРОВАИЯ Напишите программу по следующему описанию:
a. двум переменным присваиваются числовые значения;
b. если значение первой переменной больше второй, то найти разницу значений переменных (вычесть из первой вторую), результат поместить в третью переменную;
c. если первая переменная имеет меньшее значение, чем вторая, то в третью переменную поместить результат суммы значений двух первых переменных;
d. Если переменные равны, присвоить третьей переменной значение первой переменной;
e. вывести значение третьей переменной на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilya3666664
15.04.2020 07:51
Если без циклов то
program fifteen;
begin
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
writeln('Имя и фамилия');
end.

Если циклы уже
program fifteen;
var
i:integer;
begin
for i:=1 to 15 do
writeln('Имя и фамилия');
end.
0,0(0 оценок)
Ответ:
Аринка20061
04.06.2022 15:12
//В квадратной матрице A [n, n] определить количество строк упорядоченных 
//по убыванию суммы  и вывести их номера.
const n = 50;var A:Array[1..n, 1.. n] of integer;B:Array[1..n] of integer;m,i,j,sum, k, maxS, q:integer;beginwriteln('Введите размер матрицы m');readln(m);for i:= 1 to m dobeginfor j:= 1 to m dobeginA[i,j] := random(100)+1;write(A[i,j]:4);sum:= sum + A[i,j]end;B[i]:= sum;sum:=0;writeln;end;writeln('Сумма в строке ');for i:=1 to m dowriteln(i:2, B[i]:4);writeln('Матрица с убывающими строками');maxS := -1;for i:= 1 to m dobeginfor k:= 1 to m dobeginif B[k]> maxS then beginmaxS:= B[k]; q := k;end;end;B[q]:= 0; maxS := -1;for j:= 1 to m dobeginwrite(A[q,j]:4);end;writeln;
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота