ногнео
30.12.2020 00:21

Написать программу заполняющую строковой массив с размером 5 с клавиатуры , а затем произвести сложение нечётных элементов массива и из их суммы вычесть сумму чётных элементов

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sofisnow0826
14.06.2020 05:31

program raf105;

var

 a: array[1..5] of integer;

 x,sum_n,sum_c,res,i: integer;

begin

writeln('Вводите 5 чисел по очереди');

for i:=1 to 5 do

begin

 readln(x);

 if (x mod 2 = 0) and  (x <> 0)

   then sum_c:= sum_c + x;

 if x mod 2 <> 0

   then sum_n:= sum_n + x;

end;

writeln('Вывод: ',sum_n-sum_c);

end.

PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота