33zet33
16.01.2020 19:31

с информатикой. питон. Для клетки с координатами (x, y) в таблице размером M × N выведите координаты ее соседей. Соседними называются клетки, имеющие общую сторону. Входные данные Даны натуральные числа M, N, x, y (1 ≤ x ≤ M ≤ 109, 1 ≤ y ≤ N ≤ 109).

Выходные данные
В выходной файл выведите пары координат соседей этой клетки в произвольном порядке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ddddsfvxsf
20.02.2022 03:02
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
uses System.Linq;
begin
    begin
        writeln('I');
        var n := ReadInteger('n=');
        Writeln((1 + 1 + Power(2, n - 1)) * n / 2);
    end;
    
    begin
        writeln;
        writeln('II');
        var n := ReadInteger('n=');
        Writeln(n mod 11 = 0 ? 'YES' : 'NO');
        
    end;
    
    begin
        writeln;
        writeln('III');
        var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;
        writeln;
        
        while a.Any() do
        begin
            write(a[0], ' ');
            a.RemoveAt(0);
            if not a.Any then break;
            
            write(a.Last, ' ');
            a.RemoveAt(a.Count - 1);
            if not a.Any then break;
            
            var n := 0;
            if a.Count > 1 then n := a.Count div 2 - 1;
            write(a[n], ' ');
            a.RemoveAt(n);
        end;
    end;
end.
0,0(0 оценок)
Ответ:
ВиталяАрхипов
18.11.2022 20:24
1. а) Петя едет в автобусе, читает книгу и насвистывает.
    б) Петя насвистывает, когда едет в автобусе или читает книгу.
    в) Петя едет в автобусе и читает книгу или насвистывает.
    г) то же, что и а).
   д) Петя едет в автобусе или читает книгу и насвистывает.
2. а) Число 5-простое = 1.    б) Луна-спутник Венеры = 0. 
  в) Число 5-простое и Луна-спутник Венеры = 0.
г) Число 5-простое или Луна-спутник Венеры = 1.
д) Если число 5-простое, то Луна-спутник Венеры = 0.
е) Число 5-простое тогда и только тогда, когда Луна-спутник Венеры = 0.
3. а) 1999<2000 и 1999>2000
б) Петя решил все задания контрольной работы и Петя не решил все задания контрольной работы
в) Неверно, что луна спутник Земли и Неверно, что луна не является спутником Земли
г) Мишень поражена не первым выстрелом и Неверно, что мишень поражена не первым выстрелом.
4. А=1,  В=0,  С=1,  Д=0.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота