Olesya15551
03.06.2022 23:26

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nnika1015
11.06.2020 12:50

Program MAXOF3;

 

Var a,b,c,t,max: Real;

 

Begin

    Writeln('Type 3 different numbers');

    Write('a = '); Read(a);

    Write('b = '); Read(b);

    Write('c = '); Read(c);

    t := (a+b)/2 + abs(a-b)/2; {abs(x) - модуль числа х}

    max := (t+c)/2 + abs(t-c)/2;

    Writeln('max = ', max:2); {:2 - количество знаков после запятой}

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота