dimalol3373
15.10.2022 00:47

Написать программу, которая задумывает число в диапазоне от -50 до 50 и предлагает пользователю угадать число за 10 попыток (номер попытки
выводится), программа сообщает, больше или меньше загаданное число
путем вывода сообщения. После чего программа выводит на «Вам удалось!»
или «Попробуйте еще раз.».
(на Паскале)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Stan0
22.11.2020 15:41

Program zadumai;

Var

a, k, i: integer;

Begin

a:= random (101)-50;

for i := 1 to 10 do

begin

write ('Попробуйте угадать задуманное число. Попытка №', i, ': ');

readln (k);

if a=k then

begin

writeln ('Вам удалось!');

exit;

end

else

begin

end;

if a>k then writeln ('Задуманное число больше. Попробуйте еще раз.')

else writeln ('Задуманное число меньше. Попробуйте еще раз.');

end;

write (a,'-задуманное число. Попробйуйте еще раз!')

end.


Написать программу, которая задумывает число в диапазоне от -50 до 50 и предлагает пользователю угад
Написать программу, которая задумывает число в диапазоне от -50 до 50 и предлагает пользователю угад
0,0(0 оценок)
Ответ:
Ольга1738
22.11.2020 15:41

program ugadai;

var a,b,k:integer;

begin

b:=random(101)-50;

writeln('Попробуйте угадать число от -50 до 50 за 10 попыток');

writeln;

k:=1;

repeat  

write('Попытка ',k,'. Введи число: ');

readln(a);

if a>b then writeln('Загаданное число меньше!')

else if a<b then writeln('Загаданное число больше!')

else if a=b then

begin

writeln;

writeln('Вам удалось!');

k:=13;

end;

k:=k+1

until k>10;

if k=11 then

begin

writeln;

writeln('Попробуйте еще раз.')

end

end.

Объяснение:

Загадываем число (random)

Цикл с пост условием, k - счётчик попыток.

Условный оператор для корректировки угадывания.

Если все попытки исчерпаны, вывод предложения попробовать ещё раз.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота