SkeCreeper
01.03.2023 09:51

Задан двумерный массив в из 6-и строк и 3-х столбцов. составить программу, которая организует одномерный массив с, элементы которого равны количеству положительных элементов в строке исходного массива в. программа с++, найти ошибку в коде #include #include #include #include using namespace std; int main() { setlocale(lc_all, "russian"); system ("cls"); cout< < "\t \t лабораторная работа № 5. двумерный массив"< int b[6][3]; int cnt_positive[6]; int i; int j; int ki=6; //кол. строк int kj=3; //кол. столбцов for (i=0; i { for (j=0; j { cout < < "введи элемент массива b["< < i < < ","< < j < < "] = "; cin> > b[i][j]; } } cout< < "массив b" < for (i=0; i { for (j=0; j {cout< } cout< } // for (i=0; i { cnt_positive[i]=0; for (j=0; j {if(b[i][j] > 0) cnt_positive[i]++; } } cout< < "линейный массив cnt_positive[6] из матрицы b[6][3]: "< < endl; for (i=0; i< 6; i++) {cout< < cnt_positive[i] < < "\t"; } cout< < endl; system("pause"); return 0; }

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vika8330
26.01.2021 17:33

number = int(input())

last_number = 0

even = 0

odd = 0

while (number > 0):

   last_number = number % 10

   if (last_number % 2 == 0):

       even += 1

   else:

       odd += 1

   number //= 10

print("Even = ", even, "Odd = ", odd)

Объяснение:

number = int(input())  // Объявление + ввод переменной

last_number = 0  // Переменная для хранения последней цифры числа

even = 0  // Количество четных

odd = 0  // Количество нечетных

while (number > 0):  // Пока число > 0

   last_number = number % 10  // Получаем последнюю цифру числа

   if (last_number % 2 == 0):  // Если цифра делится на 2 без остатка

       even += 1  // В переменную even делаем + 1

   else:  // Иначе

       odd += 1  // В переменную odd делаем + 1

   number //= 10  // Удаляем последнюю цифру числа

print("Even = ", even, "Odd = ", odd) // Вывод

0,0(0 оценок)
Ответ:
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Матрица А ***');
  var a:=MatrRandom(4,7,-50,50); a.Println(4);
  Writeln('*** Матрица B ***');
  var b:=MatrRandom(4,7,-50,50); b.Println(4);
  Writeln(4*a.ColCount*'-');
  Writeln('*** Матрица А-B ***');
  for var i:=0 to 3 do begin
    for var j:=0 to 6 do Write(a[i,j]-b[i,j]:4);
    Writeln
    end;
end.

Пример
*** Матрица А ***
  11 -12 -37  22   3  -8  16
  -2  21  31   4  -1  13  20
  18 -42 -46 -17  19   8 -14
 -26 -32  -2  31 -26 -43 -31
*** Матрица B ***
  13 -14  12 -37   2 -12  34
  26  25 -47   2 -42   1 -43
  44  -6  -1  24  37  -9  -3
 -30   3 -29 -39 -11  -8 -14

*** Матрица А-B ***
  -2   2 -49  59   1   4 -18
 -28  -4  78   2  41  12  63
 -26 -36 -45 -41 -18  17 -11
   4 -35  27  70 -15 -35 -17
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота