SophiakoSheleva5666
23.11.2022 18:26

1. Составить программу, которая генерирует 10-значный код из букв, цифр и знаков пунктуации. 2. *Используя строковую функцию isnumber(), которая проверяет, есть ли в строке цифры, должно появляться сообщение, что пароль содержит цифры или нет ().

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Aleksandra231v
15.09.2020 00:00

Код написал на Python:

Рандомная строка из букв, цифр и знаков пунктуации:

import random

chars = "0123456789r!'#$%&()*+,-./:;<=>[email protected][\]^_`{|}~"

len_chars = len(chars)

str_result = ""

for i in range(10):

   r_number = random.randint(0,len_chars)

   str_result = str_result + chars[r_number]

print(str_result)

Проверка на цифры в строке (если будете считать как новую задачу, то знайте, кусок кода взял из первой для генерации случайной строки):

import random

chars = "0123456789r!'#$%&()*+,-./:;<=>[email protected][\]^_`{|}~"

len_chars = len(chars)

str_result = ""

for i in range(10):

   r_number = random.randint(0,len_chars)

   str_result = str_result + chars[r_number]

print(str_result)

counter = 0

for i in range(10):

   if (i == 9):

       if (str_result[i].isnumeric() == False):

           print("There is no numbers in string")

   else:

       if (str_result[i].isnumeric() == True):

           print("There is at least one number in string")

           break

       else:

           continue

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота