proulechka
13.08.2022 14:47

В какой точке окажется Чертёжник после исполнения следущей программы?
1.поднять перо
2.сместится в точку 10,10
3.опустить перо
4.нц 5 раз
5.сместится на вектор 0,2
6.сместится на вектор -1,-1
7.кц

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
JeanSu
27.05.2022 11:20
Народ последнюю задачку проверьте опять не могу найти ошибку
УСЛОВИЕ:
Дано натуральное четырехзначное число. Найти наименьшую нечетную цифру в числовой записи данного числа.
Формат входных данных
Входной файл содержит натуральное четырехзначное число.
Формат выходных данных
Выведите наименьшую нечетную цифру в числовой записи данного числа. Если нечетных цифр в числе нет, выведите в выходной файл -1.

РЕШЕНИЕ:
PascalВыделить код1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 var n,a,b,c,d:integer; f,g:text; begin assign(f,'input.txt'); assign(g,'output.txt'); reset(f); rewrite(g); readln(f,n); a:=n div 1000; b:=n div 100 mod 10; c:=(n mod 100) div 10; d:=n mod 10; if (a mod 2=0) and (b mod 2=0) and (c mod 2=0) and (d mod 2=0) and (n<>0)  then writeln(g,'-1') else if (a<=b) and (a<=c) and (a<=d) then writeln(g,a) else if (b<=a) and (b<=c) and (b<=d)then  writeln(g,b) else if (c<=a) and (c<=b) and (c<=d) then writeln(g,c) else if (d<=a) and (d<=b) and (d<=c) then writeln(g,d) else close(f); close(g); end.
0,0(0 оценок)
Ответ:
арсен2000
15.04.2020 14:05

cd ~

mkdir folder1

cd folder1

touch file1

touch file2

touch file3

touch file4

tar cvf archive.tar *

mkdir ../folder2

cd ../folder2

touch new_file

cp ../folder1/archive.tar .

tar rvf archive.tar new_file

tar vf archive.tar --delete file3

tar vf archive.tar --list > list1

tar vf ../folder1/archive.tar --list > list2

diff list1 list2

#Разъединение выполнить не получится, потому что все файлы пустые, но если засовывать не пустые, то

split -b 10M archive.tar "part" # вместо 10M нужный размер

cat part* > joined_archive.tar

tar vf archive.tar --list

tar vf joined_archive.tar --list

tar czvf final_archive.tar archive.tar ../folder1/archive.tar joined_archive.tar

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота