Rivergeenger
06.09.2020 15:22

PASCAL ABC (Через while)

Составьте программу, в которой осуществляется ввод целых двузначных чисел до тех пор, пока их сумма не превысит 1000, подсчитывается и выводится их количество и среднее арифметическое.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ddf001
17.10.2020 11:54
Структура системы это набор элементов системы и связей между ними. Например, персональный компьютер можно считать системой, где есть следующие элементы 1. блок питания 2. материнская плата 3. оперативная память 4. центральный процессор 5. видеокарта 6. сетевая карта 7. проигрыватель оптических дисков 8. модем. Операционную систему компьютера можно считать системой. Самолет типа Boeing является системой. Ракета-носитель является системой, в которой присутствует система управления, система навигации, разгонный блок, двигатель первой ступени, двигатели второй ступени, двигатели третьей ступени и др. элементы
0,0(0 оценок)
Ответ:
Sherstev
07.07.2021 06:14

Код

#include <iostream>#include <vector>int main() {    int n;    std::vector<int> sequence;    std::cin >> n;    for(auto i = 0; i < n; ++i) {        int number;        std::cin >> number;        sequence.push_back(number);    }    int as = 0, bs = 0, cs = 0;    for (auto &el : sequence) {        switch (el) {            case 1:                ++as;                break;            case 2:                ++bs;                break;            case 3:                ++cs;                break;            default:                throw std::runtime_error("All elements shall be into [1;3] range.");        }    }    int an_answer = std::min({bs + cs, as + cs, bs + cs});    std::cout << an_answer << std::endl;    return 0;}
даю (там ещё бонусом немного) Напишите прогу на C++ Задана последовательность целых чисел a1,a2,…,an
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота