annvggf
21.03.2020 15:16

Стоимость одного килограмма конфет 2,50 напишите программу которая запрашивает кол-во купленных килограмм вычисляет стоимость и выводит результат на экран

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Сонягро
21.01.2023 01:55
Напишу все же с жадным)))

// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=Arr(1000,100,50,10); // массив с достоинствами купюр
  var s:=ReadInteger('Введите сумму:'); // сумма к оплате
  Writeln('Уплатить:');
  var i:=0;
  while s>0 do begin
    var p:=s div k[i];
    if p>0 then Writeln(p,' шт. достоинством ',k[i],' руб.');
    s:=s mod k[i]; i+=1
    end;
end.

Пример
Введите сумму: 1630
Уплатить:
1 шт. достоинством 1000 руб.
6 шт. достоинством 100 руб.
3 шт. достоинством 10 руб.
0,0(0 оценок)
Ответ:
asya159
07.09.2021 14:52

Объяснение:

сть несколько перевода чисел из любой системы счисления в десятичную. Один их них основан на алгоритме для вычисления значения многочлена в некоторой точке х, который носит название вычислительной схемы Горнера.

Для перевода целых чисел из десятичной системы счисления в систему счисления с основанием р:

Последовательно делить заданное число и получаемые целые части на новое основание счисления (р) до тех пор, пока целая часть не станет ровна нулю.

Полученные остатки от деления, представленные цифрами из нового счисления, записать в виде числа, начиная с последней целой части.

Пример 1. Перевести число 61 из десятичной системы счисления в двоичную:

(В дальнейшем будет использоваться краткая запись задания: 6110 = Х2)

61 = 30 • 2 + 1;

30 = 15 • 2 + 0;

15 = 7 • 2 + 1;

7 = 3 • 2 + 1;

3 = 1 • 2 + 1;

1 = 0 • 2 + 1.

ответ: 6110 = 1111012.

(Можно заметить, что рассмотренный «Пример 1» является противоположным «Примеру 1» рассмотренному в предыдущей теме. Таким образом, всегда можно делать проверку результата при переводе чисел из любой системы счисления в десятичную, и наоборот).

Пример 2. 27110 = Х8:

271 = 33 • 8 + 7;

33 = 4 • 8 + 1;

4 = 0 • 8 +4.

ответ: 27110 = 4178.

Пример 3. 1140610 = Х16:

11406 = 712 • 16 + 14;

712 = 44 • 16 + 8;

44 = 2 • 16 +12;

2 = 0 • 16 +2.

Учитывая, что в шестнадцатеричной системе счисления числу 14 соответствует цифра Е, а числу 12 цифра С, запишем ответ:

ответ: 1140610 = 2С8Е16.

(Будет не правильно записать ответ: 1140610 = 21281416)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота