yakovlev59
27.01.2020 00:35

Задача орешки. Решить на языке Pascal.
Белочка собрала в лесу N шишек c орешками. Белочка очень привередливо выбирала шишки, и брала только те, в которых ровно M орешков. Также известно, что для пропитания зимой ей необходимо не менее K орешков. Определите, хватит ли на зиму орешков белочке.
Входные данные
Входной файл INPUT.TXT содержит три натуральных числа: N, M и K (N, M ≤ 100, K ≤ 10 000).
Выходные данные
В выходной файл OUTPUT.TXT выведите «YES» если белочке хватит орешков и «NO» в противном случае.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vansob2003
19.09.2020 04:32

k = int(0)

m = int(input("Введите M: "))

while m > 0:

 if m % 10 % 2 == 0:

   k += 1

 m //= 10

print("Четных цифр = ", k)

Объяснение:

k = int(0)  // Создание целочисленной переменной k и присвоение ей значения 0 (ноль)

m = int(input("Введите M: "))  // Ввод с клавиатуры целочисленной переменной m

while m > 0:  // Пока значение переменной m > 0

 if m % 10 % 2 == 0:  // Если остаток от деления значения переменной m на 10 и на 2 = 0

   k += 1  // К значению переменной k прибавляем 1 (единицу)

 m //= 10  // Отделяем последнее число от значения переменной m путем целочисленного деления на 10

print("Четных цифр = ", k) // Вывод значения переменной k

0,0(0 оценок)
Ответ:
maksosipow
31.01.2021 19:30
";  // Вывод сообщения в консоль

   return 1;  // Конец программы с кодом ошибки

 }

 else // Иначе

 {  

   fuel -= fuel_cons * distance_a_b;  // Емкость бака = емкость бака - расход топлива на 1 км * расстояние из пункта А в пункт В (узнаем количеств оставшегося топлива)

 }

 int distance_b_c, weight_b;   // Создание целочисленных переменных:

distance_b_c - расстояние из пункта В в пункт Сweight_b - вес груза в пункте В

 cout << "Погрузка/Разгрузка в точке B: ";  // Вывод сообщения в консоль

 cin >> weight_b;  // Ввод с клавиатуры веса груза в пункте В

 weight_a += weight_b;  // Выясняем, на сколько был дозагружен/разгружен самолет в пункте В (Вес в пункте А + Вес в пункте В)

 fuel_cons = fuel_consumption(weight_a);  // Переменной fuel_cons присваиваем возвращаемое значение из функции fuel_consumption (расход топлива на 1 км)

 cout << "Расстояние от пункта B в пункт C (км): ";  // Вывод сообщения в консоль

 cin >> distance_b_c;  // Ввод с клавиатуры расстояния из пункта В в пункт С

 fuel = (distance_b_c * fuel_cons - fuel);  // Выясняем, на сколько необходимо дозаправить самолет, чтобы долететь до пункта С (Емкость бака = расстояние из пункта В в пункт С * расход на 1 км - емкость бака)

 cout << "В пункте B самолет необходимо дозаправить на минимум (л): ";  // Вывод сообщения в консоль

 cout << fuel;  // Вывод значения переменной fuel

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота