zhezhuzina2006
29.04.2023 13:10

Напишите программу которая определяет попала ли точка с заданными координатами в заштрихованную область
входные данные -0.5 0.5 YES
0.5 -0.5 NO​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ukjlobfnjh
29.04.2022 01:15
1. Имеем дизъюнкцию (логическое или), которая ложна, если оба операнда ложны, значит, неверно, что НЕ(Первая буква гласная) и неверно, что Последняя буква гласная. Значит, первая буква гласная и последняя согласная, подходит только Егор (4).
2. Всё стоит в отрицании (НЕ), если отрицание истинно, значит, его аргумент ложен, Первая буква согласная ИЛИ Последняя буква гласная ложно. Всё аналогично первому, ответ Иван (1).
3. (X < 3) И НЕ (X < 2) = (X < 3) И (X >= 2) = (2 <= X < 3). Это неравенство выполнено для 2 (2).
4. Должно быть неверно, что третья буква гласная и неверно, что НЕ(последняя буква гласная), т.е. третья буква согласная, а последняя гласная. ответ Татьяна (2).
5. Конъюнкция (логическое И) истинно, если все операнды истинны, в данном случае НЕ(третья буква гласная)=(третья буква согласная) и (последняя буква согласная). Подходит Матвей (4).
6. Должны выполняться НЕ(количество гласных нечетно) и НЕ(первая буква согласная), т.е. кол-во гласных чётно и первая буква гласная. ответ Одоевский (2).
7. Опять конъюнкция, истинны оба операнда: НЕ(число < 20) = (число >= 20) и (число чётное). Среди вариантов есть только одно чётное число, не меньшее 20, это 36 (4).
8. Нужно слово, оканчивающееся на мягкий знак и состоящее из нечётного числа букв, это декабрь (3).
0,0(0 оценок)
Ответ:
vitalii1962svet
27.05.2022 17:36
Задачи 1,2,4:
/ PascalABC.Net 3.0, сборка 1066
var
  n:BigInteger;
begin
  var s:=ReadlnString('Введите натуральное число: ');
  If BigInteger.TryParse(s,n) then begin
    var c:=ReadChar('Введите проверяемую цифру: ');
    Writeln(c, ' встречается в ',s,' ',s.Where(x->x=c).Count,' раз');
    Writeln('Максимальная цифра числа: ',s.Where(x->x=s.Max).Distinct);
    Writeln('Перевертыш: ',s.Inverse);
    end
  else Writeln('Ошибка при вводе числа')
end.

Тестовое решение:
Введите натуральное число:  355678679650768680078676985643546809678546263435
Введите проверяемую цифру:  4
4 встречается в 355678679650768680078676985643546809678546263435 4 раз
Максимальная цифра числа: [9]
Перевертыш: 534362645876908645346589676870086867056976876553

Задача 3
// PascalABC.Net 3.0, сборка 1066
begin
  var m:int64:=-1;
  var n:int64:=0;
  Writeln('Принимаются неотрицательные целые числа');
  while (n>=0) and (m<n) do begin
    m:=n;
    n:=ReadInteger('Введите число: ')
  end;
  if m>=n then Writeln('Последовательность невозрастающая')
  else Writeln('Последовательность возрастающая')
end.

Тестовое решение:
Принимаются неотрицательные целые числа
Введите число:  4
Введите число:  6
Введите число:  12
Введите число:  83
Введите число:  170
Введите число:  214
Введите число:  170
Последовательность невозрастающая
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота