JûšțĞîřł
03.08.2022 21:19

Задано множество точек на плоскости. написать программу, которая определит среди них такую, которая содержит в заданной окрестности наибольшее количество точек множества.

входные данные: в первой строке через пробел записаны натуральное число n < = 100 - количество точек в множестве, и положительное вещественное число r < 1e+10 - радиус окрестности. в последующих n строках через пробел записаны по 2 числа - координаты x и y точек множества.

выходные данные: порядковый номер точки, в окрестности которой лежит наибольшее количество элементов множества. точки нумеруются с единицы

на языке c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikitakoshelevozt3ef
13.12.2021 07:33
ПРИЗНАКИ ИНФОРМАЦИОННОГО ОБЩЕСТВА
Осознание обществом приоритетности информации перед другим продуктом деятельности человека.
Первоосновой всех направлений деятельности человека (экономической, производственной, политической, образовательной, научной, творческой, культурной и т.п.) является информация.
Информация же является продуктом деятельности современного человека.
Информация в чистом виде (сама по себе) является предметом купли – продажи.
Равные возможности в доступе к информации всех слоев населения.
Безопасность информационного общества, информации.
Защита интеллектуальной собственности.
Взаимодействие всех структур государства и государств между собой на основе ИКТ.
Управление информационным обществом со стороны государства, общественных организаций.
Кроме положительных моментов прогнозируются и опасные тенденции:
все большее влияние на общество средств массовой информации;
информационные технологиимогут разрушить частную жизнь людей и организаций;
существует проблема отбора качественной и достоверной информации;
многим людям будет трудно адаптироваться к среде информационного общества.
существует опасность разрыва между "информационной элитой" (людьми,
занимающимися разработкой информационных технологий) и потребителями.
0,0(0 оценок)
Ответ:
kuznecovamargo
02.09.2022 01:44
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
      int n;
      cout<<"n = ";  cin>>n;   // ввод количества элементов массива 
      int a[n];
// заполнение массива и вывод на экран
      for (int i=0;i<n;i++) { 
           a[i]=rand()%15;     cout<<a[i]<<" "; 
      } 
      cout<<endl;  // перевод строки
// сортировка массива по возрастанию
      for (int i=0; i<n-1; i++)
      for (int j=i+1; j<n; j++) 
           if (a[i]>a[j]) swap(a[i],a[j]);
// вывод 4 минимальных
      cout<<"four min numbers:  ";
      for (int i=0; i<4; i++)  cout<<a[i]<<" ";
      cout<<endl;
      system("pause");  // ожидание ввода с клавиатуры
      return 0;
  }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота