плвлаовг
21.10.2022 16:36

Написать программу в паскале(строковые и символьные величины)

вводится предложение из 2-х одинаковых по длине слов. вывести на экран большее из них.

нужно!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Danil111112
16.12.2021 15:21
1. Как выше уже сказали, имя файла ОБЫЧНО состоит и правда из двух частей. Это придумали еще давно, сначала просто для удобства, чтобы понимать, что за информация содержится внутри (текст, звук и т. д.) . Впоследствии операционные системы стали использовать расширение для распознавания содержимого и запуска необходимого приложения для обработки файла, или распознавала, что файл является программой и запускается сам (это в Windows и DOS файлы с расширением *.exe, *.bat, *.com) а вот в Линуксе исполняемый файл может иметь любое расширение, или вообще его не иметь. В Windows ( а ранее в DOS) использовалось расширение с ограничениями, в три знака. Сейчас Windows использует и больше знаков для работы (например *.docx). В принципе имя файла может состоять хоть из одной, хоть из десяти частей. Главное его открыть нужной программой, чтобы прочитать.
0,0(0 оценок)
Ответ:
linaaalinaa
14.11.2022 18:08
Для радиуса описанной окружности имеется соотношение
\displaystyle R= \frac{a}{2\sin A}=\frac{b}{2\sin B}=\frac{c}{2\sin C}; \\ \\ a=2R\sin A \\ b=2R\sin B \\ c=2R\sin C

// PascalABC.NET 3.2, сборка 1367 от 20.12.2016
// Внимание! Если программа не работает, обновите версию!

var
  a,b,c,R,dA,dB,dC:real;
begin
  Writeln('Введите углы A,B в градусах и радиус R');
  Read(dA,dB,R);
  dC:=180-dA-dB;
  a:=2*R*sin(dA*Pi/180);
  b:=2*R*sin(dB*Pi/180);
  c:=2*R*sin(dC*Pi/180);
  Writeln('Угол C: ',dC:0:2);
  Writeln('a=',a:0:5);
  Writeln('b=',b:0:5);
  Writeln('c=',c:0:5)
end.

Пример
Введите углы A,B в градусах и радиус R
30 70 50.0
Угол C: 80.00
a=50.00000
b=93.96926
c=98.48078
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота